<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html prefix="og: http://ogp.me/ns#" xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-gb" lang="en-gb">
<head>
    	<base href="http://www.whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" />
	<meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta name="keywords" content="Caribbean news,latest news, Cayman" />
	<meta name="rights" content="All rights reserved. Whats Up Caribbean Ltd" />
	<meta name="title" content="Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case" />
	<meta name="author" content="editor" />
	<meta property="og:url" content="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" />
	<meta property="og:title" content="What's Up Caribbean  - Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case" />
	<meta property="og:type" content="article" />
	<meta property="og:description" content="Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case" />
	<meta name="description" content="Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case" />
	<meta name="generator" content="Joomla! - Open Source Content Management" />
	<title>What's Up Caribbean  - Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case</title>
	<link href="/index.php?option=com_ajax&plugin=arktypography&format=json" rel="stylesheet" type="text/css" />
	<link href="/index.php?option=com_ajax&plugin=arkbootstrap&format=json" rel="stylesheet" type="text/css" />
	<link href="/media/k2/assets/css/magnific-popup.css?v2.7.1" rel="stylesheet" type="text/css" />
	<link href="/media/k2/assets/css/k2.fonts.css?v2.7.1" rel="stylesheet" type="text/css" />
	<link href="/templates/gk_twn2/css/k2.css?v2.7.1" rel="stylesheet" type="text/css" />
	<link href="http://whatsupcaribbean.com//plugins/content/bt_socialshare/assets/bt_socialshare.css" rel="stylesheet" type="text/css" />
	<link href="http://www.whatsupcaribbean.com/templates/gk_twn2/css/mobile/handheld.css" rel="stylesheet" type="text/css" />
	<link href="http://www.whatsupcaribbean.com/media/editors/arkeditor/css/squeezebox.css" rel="stylesheet" type="text/css" />
	<style type="text/css">
.fballshare_left {float:left}.fballshare {margin:0px}.fball_fblike {width:120px}.fballshare .fball_fblike span{height: 40px!important;width: 535px!important;}.fball_pinterest, .fball_linkedin,.fball_digg {margin-right:10px}.fball_pinterest a {float:left}.fball_plusone {width:70px}.fball_twitter {width:106px}.fballshare_left {float:left}.fballshare {margin:0px}.fball_fblike {width:120px}.fballshare .fball_fblike span{height: 40px!important;width: 535px!important;}.fball_pinterest, .fball_linkedin,.fball_digg {margin-right:10px}.fball_pinterest a {float:left}.fball_plusone {width:70px}.fball_twitter {width:106px}.fballshare_left {float:left}.fballshare {margin:0px}.fball_fblike {width:120px}.fballshare .fball_fblike span{height: 40px!important;width: 535px!important;}.fball_pinterest, .fball_linkedin,.fball_digg {margin-right:10px}.fball_pinterest a {float:left}.fball_plusone {width:70px}.fball_twitter {width:106px}.fballshare_left {float:left}.fballshare {margin:0px}.fball_fblike {width:120px}.fballshare .fball_fblike span{height: 40px!important;width: 535px!important;}.fball_pinterest, .fball_linkedin,.fball_digg {margin-right:10px}.fball_pinterest a {float:left}.fball_plusone {width:70px}.fball_twitter {width:106px}.fballshare_left {float:left}.fballshare {margin:0px}.fball_fblike {width:120px}.fballshare .fball_fblike span{height: 40px!important;width: 535px!important;}.fball_pinterest, .fball_linkedin,.fball_digg {margin-right:10px}.fball_pinterest a {float:left}.fball_plusone {width:70px}.fball_twitter {width:106px}.fballshare_left {float:left}.fballshare {margin:0px}.fball_fblike {width:120px}.fballshare .fball_fblike span{height: 40px!important;width: 535px!important;}.fball_pinterest, .fball_linkedin,.fball_digg {margin-right:10px}.fball_pinterest a {float:left}.fball_plusone {width:70px}.fball_twitter {width:106px}
	</style>
	<script src="/media/jui/js/jquery.min.js" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-noconflict.js" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
	<script src="/media/k2/assets/js/jquery.magnific-popup.min.js?v2.7.1" type="text/javascript"></script>
	<script src="/media/k2/assets/js/k2.frontend.js?v2.7.1&amp;sitepath=/" type="text/javascript"></script>
	<script src="http://assets.pinterest.com/js/pinit.js" type="text/javascript"></script>
	<script src="http://platform.linkedin.com/in.js" type="text/javascript"></script>
	<script src="http://platform.twitter.com/widgets.js" type="text/javascript"></script>
	<script src="https://apis.google.com/js/plusone.js" type="text/javascript"></script>
	<script src="/media/jui/js/bootstrap.min.js" type="text/javascript"></script>
	<script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
	<script src="/media/system/js/core.js" type="text/javascript"></script>
	<script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
	<script src="http://www.whatsupcaribbean.com/templates/gk_twn2/js/mobile/gk.handheld.js" type="text/javascript"></script>
	<script src="http://www.whatsupcaribbean.com/media/editors/arkeditor/js/jquery.easing.min.js" type="text/javascript"></script>
	<script src="http://www.whatsupcaribbean.com/media/editors/arkeditor/js/squeezebox.min.js" type="text/javascript"></script>
	<script type="text/javascript">

(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));
					(function() {
					  var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
					  s.type = 'text/javascript';
					  s.async = true;
					  s.src = 'http://widgets.digg.com/buttons.js';
					  s1.parentNode.insertBefore(s, s1);
					})();				
				
					(function() {
					  var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
					  s.type = 'text/javascript';
					  s.async = true;
					  s.src = 'http://widgets.digg.com/buttons.js';
					  s1.parentNode.insertBefore(s, s1);
					})();				
				
					(function() {
					  var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
					  s.type = 'text/javascript';
					  s.async = true;
					  s.src = 'http://widgets.digg.com/buttons.js';
					  s1.parentNode.insertBefore(s, s1);
					})();				
				
					(function() {
					  var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
					  s.type = 'text/javascript';
					  s.async = true;
					  s.src = 'http://widgets.digg.com/buttons.js';
					  s1.parentNode.insertBefore(s, s1);
					})();				
				
					(function() {
					  var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
					  s.type = 'text/javascript';
					  s.async = true;
					  s.src = 'http://widgets.digg.com/buttons.js';
					  s1.parentNode.insertBefore(s, s1);
					})();				
				
					(function() {
					  var s = document.createElement('SCRIPT'), s1 = document.getElementsByTagName('SCRIPT')[0];
					  s.type = 'text/javascript';
					  s.async = true;
					  s.src = 'http://widgets.digg.com/buttons.js';
					  s1.parentNode.insertBefore(s, s1);
					})();				
				(function()
				{
					if(typeof jQuery == 'undefined')
						return;
					
					jQuery(function($)
					{
						if($.fn.squeezeBox)
						{
							$( 'a.modal' ).squeezeBox({ parse: 'rel' });
				
							$( 'img.modal' ).each( function( i, el )
							{
								$(el).squeezeBox({
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							})
						}
						else if(typeof(SqueezeBox) !== 'undefined')
						{
							$( 'img.modal' ).each( function( i, el )
							{
								SqueezeBox.assign( el, 
								{
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							});
						}
						
						function jModalClose() 
						{
							if(typeof(SqueezeBox) == 'object')
								SqueezeBox.close();
							else
								ARK.squeezeBox.close();
						}
					
					});
				})();
	</script>
	<meta property="og:type" content="website" />
	<meta property="og:title" content="Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case" />
	<meta property="og:url" content="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" />
	<meta property="og:description" content="Ato Modibo Stephens has been extradited from the United States to the Cayman Islands to face allegations of sexual abuse while he worked as a coach here. The 37-year-old Olympic athlete, who is married to Cayman&rsquo;s track star Cydonie Mothersill, is charged with indecent assault, gross indecency" />
	<meta property="og:image" content="http://whatsupcaribbean.com/images/Ato.jpg" />
	<meta property="fb:app_id" content="183374725037791" />

    <meta name="viewport" content="width=device-width, minimum-scale=1.0, maximum-scale=1.0" />
    </head>
<body>
    <div id="gkWrap">
    	<div id="gkTopWrap">
    		            <h1 id="gkHeader">
                <a href="/./"><img src="http://www.whatsupcaribbean.com/images/banners/whatsupcaribbean728x90.jpg" alt="What's Up Caribbean " /></a>    
                        </h1>
    	
    		    		
    		    		
    		    	</div>
    	
    	<div id="gkNav">
    		<div id="gkNavContent">
    			<select id="gkMenu" onchange="window.location.href=this.value;">
    			<option  value="http://www.whatsupcaribbean.com/">Home</option><option  value="/general">General</option><option  value="/business">Business</option><option  value="/entertainment">Entertainment</option><option  value="/health">Health</option><option selected="selected"  value="/sports">Sports</option><option  value="/technology">Technology</option><option  value="/travel">Travel</option><option  value="/photogallery">Photogallery</option><option  value="/editorials">Editorials</option>    			</select>
    		</div>
    	</div>

		    	
    	<div id="gkContent">
	    		    	
	    	<div id="gkMain">
	    		<div id="system-message-container">
	</div>

	    		

<!-- Start K2 Item Layout -->

<span id="startOfPageId24568"></span>
<div id="k2Container" class="itemView itemIsFeatured">
      
      <!-- Plugins: BeforeDisplay -->
      
            
      <!-- K2 Plugins: K2BeforeDisplay -->
      
                  <div class="itemHeader">
            
			    			      <div class="itemToolbar">
			            			            
			            <!-- Item title -->
			            
			            <h2 class="itemTitle">
			                  Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case			                  			                  
			                  <!-- Featured flag -->
			                  
			                  <span>
			                  <sup>
			                  Featured			                  </sup>
			                  </span>
			                  			            </h2>
			            			            
			            
			            <ul>
			                                                			              
			                  <!-- Date created -->
			                  
			                  <li>
                                <time datetime="2017-02-24T07:36:15-04:00">
			                    Friday, 24 February 2017 07:36                                </time>
			                  </li>
			                  
			                  			                  			                  
			                  <!-- Font Resizer -->
			                  
			                  <li>
			                        <span class="itemTextResizerTitle">font size</span>
			                        <a href="#" id="fontDecrease">
			                              <span>decrease font size</span>
			                              <img src="/components/com_k2/images/system/blank.gif" alt="decrease font size" />
			                        </a>
			                        <a href="#" id="fontIncrease">
			                              <span>increase font size</span>
			                              <img src="/components/com_k2/images/system/blank.gif" alt="increase font size" />
			                        </a>
			                  </li>
			                  			                  				                     <!-- Print Button -->
			                      <li>
				                  <a class="itemPrintLink" rel="nofollow" href="/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
					              <span>Print</span>
				                  </a>
			                      </li>
			                  			                  			                      <!-- Email Button -->
			                      <li>
				                   <a class="itemEmailLink" rel="nofollow" href="/component/mailto/?tmpl=component&amp;template=gk_twn2&amp;link=9c3955705a0dfb6718a4ac05bbc97727570bbced" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
					                <span>Email</span>
				                   </a>
			                      </li>
			                  			                  			                  			                  			                  			            </ul>
			            <div class="clr"></div>
			                   <!-- Item Rating -->
			              			      </div>
			            
      </div>
      
      <!-- Plugins: AfterDisplayTitle -->
      
            
      <!-- K2 Plugins: K2AfterDisplayTitle -->
      
            
      <div class="itemBody">
            
            <!-- Plugins: BeforeDisplayContent -->
            
                        
            <!-- K2 Plugins: K2BeforeDisplayContent -->
            
                                                            
            <!-- Item introtext -->
            
            <div class="itemIntroText">
                  <div class="bt-social-share bt-social-share-above"><div class="bt-social-share-button bt-facebook-share-button"><fb:share-button href="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" type="button_count"></fb:share-button></div><div class="bt-social-share-button bt-facebook-like-button"><div class="fb-like" data-href="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" data-colorscheme="light" data-font="arial" data-send="false" data-layout="button_count" data-width="70" data-show-faces="true" data-action="recommend"></div></div><div class="bt-social-share-button bt-twitter-button" style="width:80px"><a href="http://twitter.com/share" class="twitter-share-button" 
						  data-via="BowThemes" 
						  data-url="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" 
						  data-size="medium"
						  data-lang="en"
						  data-count="horizontal" >Twitter</a></div><div class="bt-social-share-button bt-linkedin-button"><script type="IN/share" data-url="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case"
						 data-showzero="false"
						 data-counter="right"></script></div><div class="bt-social-share-button bt-googleplus-button"><g:plus action="share" href="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" annotation="bubble" height="20" ></g:plus></div></div><p style="text-align: justify;"><img src="/images/Ato.jpg" alt="" style="float: left;" />Ato Modibo Stephens has been extradited from the United States to the Cayman Islands to face allegations of sexual abuse while he worked as a coach here. The 37-year-old Olympic athlete, who is married to Cayman&rsquo;s track star Cydonie Mothersill, is charged with indecent assault, gross indecency and misuse of an ICTA network involving a minor.</p>
<p style="text-align: justify;">            </div>
                                    
            <!-- Item fulltext -->
            
            <div class="itemFullText">
                  </p>
<p style="text-align: justify;">He arrived in Cayman this week following successful extradition from the US, where he has citizenship.</p>
<p style="text-align: justify;">Stephens lived in Bodden Town when he was in Cayman and working with local athletes as a track coach with his wife. He is alleged to have indecently assaulted a teenager but left the jurisdiction some twelve months ago, after the young girl made the report and well before the charges were laid by police in June 2016.</p>
<p style="text-align: justify;">Born in Trinidad, Stephens is a sprinter specialising in the 400 metres who competed in the 2000, 2004 and 2008 Olympics but did not get past the heats.</p>
<p style="text-align: justify;">In 2009 he failed a drugs test at an international competition, testing positive for Oxandrolone, Stanozolol and Tamoxifen. He was banned from competition for two years for the infraction.</p><div class="fb-recommendations-bar" data-href="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" data-read-time="30" data-action="recommend" data-trigger="onvisible" data-side="right" data-num_recommendations="2"></div><div id="fb-root"></div>
				<script>(function(d, s, id) {
				  var js, fjs = d.getElementsByTagName(s)[0];
				  if (d.getElementById(id)) {return;}
				  js = d.createElement(s); js.id = id;
				  js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1&appId=183374725037791";
				  fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));</script><script src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script type="text/javascript" src="//platform.linkedin.com/in.js"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js">{lang: 'en-GB'}</script>            </div>
                                    <div class="clr"></div>
                                    
            <!-- Plugins: AfterDisplayContent -->
            
            <div style='padding-bottom:5px;padding-top:5px;'><div class="fb-comments" data-href="http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case" data-width="500" data-num-posts="10" data-colorscheme="light"></div> </div><div style='padding-bottom:5px;padding-top:5px;'><div id='fb-root'></div><div class='fballshare'><div class='fball_linkedin fballshare_left'><script type='IN/Share' data-url=http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case data-counter='right'></script></div><div class='fball_twitter fballshare_left'><a href='http://twitter.com/share' class='twitter-share-button' data-text='Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case' data-url='http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case' data-count='horizontal'>Tweet</a></div><div class='fball_plusone fballshare_left'><g:plusone href='http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case' size='medium'></g:plusone></div><div class='fball_pinterest fballshare_left'><a data-pin-config='beside' href='//pinterest.com/pin/create/button/?url=http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case&media=http://whatsupcaribbean.com/images/Ato.jpg&description=Cayman Islands: Trinidad born Olympic athlete extradited in sex-crime case' data-pin-do = 'buttonPin' ><img src='//assets.pinterest.com/images/pidgets/pin_it_button.png'/></a></div><div class='fball_digg fballshare_left'><a class='DiggThisButton DiggCompact' href='http://digg.com/submit?url='http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case'></a></div><div class='fball_fblike fballshare_left'><div class='fb-like' data-href='http://whatsupcaribbean.com/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case' data-send='false' data-layout='button_count' data-width='120' data-show-faces='flase'></div></div><div style='clear:both'></div></div> </div>            
            <!-- K2 Plugins: K2AfterDisplayContent -->
            
                        <div class="clr"></div>
      </div>
            <div class="itemLinks">
                                    
            <!-- Item category name -->
            
            <div class="itemCategory">
                  <span>Published in</span>
                  <a href="/sports">Sports</a>
            </div>
                                    
            <!-- Item tags -->
            
            <div class="itemTagsBlock">
                  <span>Tagged under</span>
                  <ul class="itemTags">
                                                <li>
                              <a href="/sports/itemlist/tag/Trinidad%20&amp;%20Tobago">Trinidad & Tobago</a>
                        </li>
                                                <li>
                              <a href="/sports/itemlist/tag/Cayman">Cayman</a>
                        </li>
                                          </ul>
                  <div class="clr"></div>
            </div>
                                        <!-- Social sharing -->
                <div class="itemSocialSharing">
            
                                        <!-- Twitter Button -->
                    <div class="itemTwitterButton">
                       <a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal">
				       Tweet			           </a>
			           <script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
		            </div>
                                        
                                        <!-- Facebook Button -->
                    <div class="itemFacebookButton">
                        <script type="text/javascript">                                                         
						window.addEvent('load', function(){
							  (function(){
										  if(document.id('fb-auth') == null) {
										  var root = document.createElement('div');
										  root.id = 'fb-root';
										  $$('.itemFacebookButton')[0].appendChild(root);
										  (function(d, s, id) {
											var js, fjs = d.getElementsByTagName(s)[0];
											if (d.getElementById(id)) return;
											js = d.createElement(s); js.id = id;
											js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
											fjs.parentNode.insertBefore(js, fjs);
										  }(document, 'script', 'facebook-jssdk')); 
									  }
							  }());
						  });
						</script>
                        <div class="fb-like" data-send="false" data-width="260" data-show-faces="true"></div>
                    </div>
                                
                                        <!-- Google +1 Button -->
                    <div class="itemGooglePlusOneButton">	
                        <g:plusone annotation="inline" width="120"></g:plusone>
                        <script type="text/javascript">
                          (function() {
                            window.___gcfg = {lang: 'en'}; // Define button default language here
                            var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                            po.src = 'https://apis.google.com/js/plusone.js';
                            var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
                          })();
                        </script>
                    </div>
                                        
                    <div class="clr"></div>
                </div>
                                        <div class="clr"></div>
      </div>
                        		
            
      <!-- Related items by tag -->
      
      <div class="itemRelated">
            <h3>Related items</h3>
            <ul>
						<li class="even">
			
								<a class="itemRelTitle" href="/general/item/24567-gay-rights-advocate-challenges-t-t-s-homosexuality-laws">Gay-rights advocate challenges T&amp;T&#039;s homosexuality laws</a>
				
								<div class="itemRelCat">in <a href="/general">News</a></div>
								
								
								
								
				
												<div class="itemRelMedia"></div>
												
								<div class="itemRelImageGallery"></div>
							</li>
						<li class="odd">
			
								<a class="itemRelTitle" href="/business/item/24557-130-000-heist-at-massy-stores-trinidad">$130,000 heist at Massy Stores Trinidad</a>
				
								<div class="itemRelCat">in <a href="/business">Business</a></div>
								
								
								
								
				
												<div class="itemRelMedia"></div>
												
								<div class="itemRelImageGallery"></div>
							</li>
						<li class="even">
			
								<a class="itemRelTitle" href="/business/item/24531-questions-raided-over-steven-mnuchin-pick-as-treasury-secretary">Questions raided over Steven Mnuchin pick as Treasury Secretary</a>
				
								<div class="itemRelCat">in <a href="/business">Business</a></div>
								
								
								
								
				
												<div class="itemRelMedia"></div>
												
								<div class="itemRelImageGallery"></div>
							</li>
						<li class="odd">
			
								<a class="itemRelTitle" href="/item/24527-d-chancellor-brings-forth-carnival-2017-track-wajank">D’ Chancellor brings forth Carnival 2017 track “Wajank”</a>
				
								<div class="itemRelCat">in <a href="/itemlist/category/37-featured-artiste">Featured Artiste</a></div>
								
								
								
								
				
												<div class="itemRelMedia"></div>
												
								<div class="itemRelImageGallery"></div>
							</li>
						<li class="even">
			
								<a class="itemRelTitle" href="/general/item/24517-trinidad-cultural-icon-anand-yankarran-dies">Trinidad Cultural Icon Anand Yankarran Dies</a>
				
								<div class="itemRelCat">in <a href="/general">News</a></div>
								
								
								
								
				
												<div class="itemRelMedia"></div>
												
								<div class="itemRelImageGallery"></div>
							</li>
						<li class="clr"></li>
		</ul>
            <div class="clr"></div>
      </div>
            <div class="clr"></div>
                        
      <!-- Item navigation -->
      
      <div class="itemNavigation">
            <span class="itemNavigationTitle">More in this category:</span>
                        <a class="itemPrevious" href="/sports/item/24561-marlon-samuels-allowed-to-resume-bowling-international-cricket">
                  &laquo;
                  Marlon Samuels allowed to resume bowling International Cricket            </a>
                              </div>
            
      <!-- Plugins: AfterDisplay -->
      
            
      <!-- K2 Plugins: K2AfterDisplay -->
      
                       		<div class="itemBackToTop">
		<a class="k2Anchor" href="/sports/item/24568-cayman-islands-trinidad-born-olympic-athlete-extradited-in-sex-crime-case#startOfPageId24568">
			back to top		</a>
	</div>
	      <div class="clr"></div>
</div>

<!-- End K2 Item Layout -->


<!-- JoomlaWorks "K2" (v2.7.1) | Learn more about K2 at http://getk2.org -->


	    	</div>
	    	
	    		 
	    	<div id="gkFooter">
	    		<p id="gkCopyrights">Copyright Whats Up Caribbean 2016</p>
	    		
	    		<p id="gkOptions">
	    			<a href="#gkHeader">Top</a>
	    			<a href="javascript:setCookie('gkGavernMobiletwn', 'desktop', 365);window.location.reload();">Desktop version</a>
	    		</p>
	    	</div>
    	</div>
	</div>
	
	</body>
</html>